cPanel & WHM no longer develops EasyApache 3 and only releases security updates for it. We will deprecate EasyApache 3 on December 31, 2018. After that date, we will no longer update EasyApache 3. In cPanel & WHM version 78, we will remove support for EasyApache 3. For more information, read our cPanel Long-Term Support documentation. If you do not upgrade to EasyApache 4, you cannot upgrade to cPanel & WHM version 78. We strongly recommend that you upgrade to EasyApache 4. For more information, read our EasyApache 4 documentation.
PHP Module: Zip - EasyApache - cPanel Documentation
Page tree
Skip to end of metadata
Go to start of metadata

Overview

zip – Read or write ZIP compressed archives

Profile

Namezip
PHP Version5
Profile ValueCpanel::Easy::PHP5::zip
Reverse BooleanNo

Compatibility

This module has no known compatibility issues.

Notes

The following paths are searched for libz.so:

  • /usr/lib64
  • /usr/local/lib64
  • /usr/local/lib
  • /lib64
  • /lib

If libz.so is found in one of the referenced paths, the --with-zlib-dir directory is added to PHP's configure line. Otherwise, this module is disabled.

A short test script is created (cpzlib.c) that simply includes zlib.h as a basic sanity check. If compilation fails, this module is disabled.

If you enable this option, --enable-zip will be added to PHP's configuration options.

Requirements

OSOS VersionRPM/Package
CentOS/Red HatAllzlib-devel

Vendor documentation

PHP versionDocumentation
5Docs