cPanel & WHM no longer develops EasyApache 3 and only releases security updates for it. We will deprecate EasyApache 3 on December 31, 2018. After that date, we will no longer update EasyApache 3. In cPanel & WHM version 78, we will remove support for EasyApache 3. For more information, read our cPanel Long-Term Support documentation. If you do not upgrade to EasyApache 4, you cannot upgrade to cPanel & WHM version 78. We strongly recommend that you upgrade to EasyApache 4. For more information, read our EasyApache 4 documentation.
PHP Module: MySQL of the System - EasyApache - cPanel Documentation
Page tree
Skip to end of metadata
Go to start of metadata

Overview

The mysqlofsystem module tells PHP to use the MySQL® libraries for PHP.

Profile

Namemysqlofsystem
PHP Version5
Profile ValueCpanel::Easy::PHP5::MysqlOfSystem
Reverse BooleanNo

Compatibility

As of PHP 5.4, MySQL of the System does not support short passwords.

MySQL of the System is not compatible with MySQL 5.6 or later or MariaDB 10 or later. If you install either of these, the system will disable MySQL of the System and use mysqlnd, the MySQL Native Driver, instead.

Notes

When MySQL of the System is enabled, the system uses the libmysqlclient library.

When MySQL of the System is disabled, the system uses the mysqlnd MySQL Native Driver.

Important:

You must disable both MySQL and MySQL of the System and leave only MySQLi compiled into PHP to use mysqlnd.

Vendor documentation

PHP versionDocumentation
5N/A

Other documentation