Page tree
Skip to end of metadata
Go to start of metadata

Last updated 

Modified or updated features

PHP 5.5

The latest version of PHP 5.5 is version 5.5.15.

PHP 5.4

The latest version of PHP 5.4 is version 5.4.31.

FCGI

The latest version of FCGI is 2.3.9.

ModSecurity

The latest version of ModSecurity is 2.8.0.

IonCube Loader

The latest version of IonCube Loader is 4.6.1.

Removed features

mod_frontpage removed

Because Microsoft® discontinued support for mod_frontpage extensions on Linux servers in 2006, we have discontinued support for the FrontPage service in cPanel & WHM. FrontPage extensions are now only available as a Custom Module (“Opt Mods”) for EasyApache. The mod_frontpage custom module is only compatible with Apache version 2.2.

Warning:

We strongly discourage use of the mod_frontpage custom module. We recommend that you use another method to publish, such as WebDAV or FTP.

  • For more information about WebDAV, read our Web Disk documentation.
  • For more information about FTP, read our FTP Accounts documentation.

PHP version 5.2 removed

Because PHP version 5.2 reached End of Life in 2011, we have discontinued support for PHP version 5.2.

If your EasyApache profile includes PHP 5.2, EasyApache will upgrade your PHP installation to version 5.4.

For more information on how to upgrade your server to PHP version 5.4, read the following documentation:

Apache version 1.3 removed

Because Apache version 1.3 reached End of Life in 2010, we have discontinued support for Apache version 1.3. 

If your EasyApache profile includes Apache version 1.3, EasyApache will upgrade your Apache installation to version 2.2.

Apache version 2.0 removed

Because Apache version 2.0 reached End of Life in 2013, we have discontinued support for Apache version 2.0. EasyApache no longer includes an option for Apache version 2.0.

If your EasyApache profile includes Apache version 2.0, EasyApache will upgrade your Apache installation to version 2.2.

  • For more information on Apache version 2.0, read the Apache 2.0 Announcement.
  • For more information on how to upgrade your server from Apache 2.0 to Apache 2.2, read the Upgrading documentation for version 2.2.
  • For more information on features in Apache version 2.2, read Apache's Overview of new features in Apache 2.2.

Appendix A

Mod Security now compatible with Mod Ruid2

We have upgraded Mod Security to resolve compatibility issues with Mod Ruid2.

If you install Mod Ruid2 and Mod Security, the Mod Security log location is: /usr/local/apache/logs/modsec_audit/[user]/YYYYMMDD/YYYYMMDD-HHmm/YYYYMMDD-HHmmSS-[unique_id]