Child pages
  • WHM API 1 Functions - modsec_is_installed
Skip to end of metadata
Go to start of metadata

Description

This function checks whether the ModSecurity™ module is installed.

Important:

In cPanel & WHM version 76, the WebServer role affects this function.

Examples


 JSON API
https://hostname.example.com:2087/cpsess##########/json-api/modsec_is_installed?api.version=1
 XML API
https://hostname.example.com:2087/cpsess##########/xml-api/modsec_is_installed?api.version=1
 Command Line
whmapi1 modsec_is_installed


Notes:

  • You must URI-encode values.
  • For more information and additional output options, read our Guide to WHM API 1 documentation or run the whmapi1 --help command.
  • If you run CloudLinux™, you must use the full path of the whmapi1 command:

    /usr/local/cpanel/bin/api/whmapi1

 Output (JSON)
{
   "data": {
        "data": {
            "installed": 1
        }
    },
    "metadata": {
        "version": 1,
        "reason": "OK",
        "result": 1,
        "command": "modsec_is_installed"
    }
}
 Output (XML)
<result>
   <data>
      <data>
         <installed>1</installed>
      </data>
   </data>
   <metadata>
      <version>1</version>
      <reason>OK</reason>
      <result>1</result>
      <command>modsec_is_installed</command>
   </metadata>
</result>


Note:

Use WHM's API Shell interface (WHM >> Home >> Development >> API Shell) to directly test WHM API calls.

Parameters

This function does not accept parameters.

Returns

ReturnTypeDescriptionPossible valuesExample
installedBooleanWhether ModSecurity is installed on the server.
  • 1 — Installed.
  • 0Not installed.
 1