Page tree
Skip to end of metadata
Go to start of metadata

Overview

Requirements

Install Ruby

Troubleshoot your installation

Uninstall Ruby

yum

rpm

Manual compilation


Important:

 Ruby on Rails does not function on Amazon Linux servers and is not supported on CentOS 7 servers.


Uninstall Ruby with the rpm command

To determine whether Ruby exists on your server, run the following command:

rpm -qa|grep -i ruby 

The command returns output that resembles the following example:

# rpm -qa|grep -i ruby
rubygems-1.3.7-5.el6.noarch
ruby-rdoc-1.8.7.374-4.el6_6.i686
ruby-libs-1.8.7.374-4.el6_6.i686
ruby-devel-1.8.7.374-4.el6_6.i686
ruby-1.8.7.374-4.el6_6.i686
ruby-irb-1.8.7.374-4.el6_6.i686

To remove a package, run the rpm  e --nodeps packagename command, where packagename represents the name of a package.

Additional documentation